BRIDGING ATM

 

Descrizione del problema:

   Si devono collegare due LAN remote. Una rete LAN e' a MESSINA. Una seconda con i server centrali e' a CATANIA. Il collegamento dev'essere di Livello 2 (DATALINK), ovvero dev'essere fatto un bridging. Questo perche' abbiamo due architetture con VLAN e vogliamo riportare esattamente le VLAN di CATANIA su MESSINA. Ad esempio stiamo facendo una migrazione e dovremo spostare alcuni server da CATANIA a MESSINA senza creare disservizio o doverli riconfigurare in IP, NETMASK e GATEWAY, il quale e' un IP di CATANIA e tale deve restare. Gli host di MESSINA hanno un collegamento privato con CATANIA ed escono su INTERNET da CATANIA. A MESSINA vi sono due router, uno primario con collegamento WAN a 155 mbps, e uno di backup con collegamento WAN a 34mbps. I due collegamenti sono in tecnologia ATM e i circuiti sono punto-punto su Catania. Siamo cosi' liberi di scegliere i PVC che preferiamo in quanto il fornitore del collegamento ci ha riservato un intero canale ATM. Essendo due i collegamenti paralleli confidiamo nello STP per evitare la presenza di loop e quindi gestire il backup: il collegamento a 155 mbps deve avere priorita' superiore.

- Il transparent-bridging consiste nel far funzionare il router come uno switch. Pertanto si deve disabilitare il routing con il comando "no ip routing";
- L'integrated routing and bridging (IRB) consiste nell'utilizzare contemporaneamente il routing e lo switching senza disabilitare il routing.

Esempio di IRB

 

ip routing
!
bridge irb
!
interface FastEthernet0/0
description --- rete interna ---
 no ip address
 bridge-group 1
!
interface FastEthernet0/1
description --- rete esterna ---
no ip address
bridge-group 1
!
interface BVI1         <--- Nota che "1" qui lega l'interfaccia al "bridge-group 1"  (*)
ip address 192.168.30.188 255.255.255.0
!
bridge 1 protocol ieee
bridge 1 route ip 
!

(*) Questa interfaccia va creata dopo aver attivato IRB altrimenti:

test(config)#int bvi 1
Integrated Routing and Bridging is not configured!

Esempio di transparent-bridging (no routing)

Configurazione di MESSINA-1:

messina-1#sh run
Building configuration...

Current configuration : 3306 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime localtime
service password-encryption
!
hostname messina-1
!
...snip...
no ip routing      <---  ABILITA IL TRANSPARENT BRIDGING ALTRIMENTI NON FUNZIONA IL BRIDGING 
!
...snip...
!
interface FastEthernet0/0
description verso RETE DI MONITORAGGIO
ip address 192.168.30.120 255.255.255.128
...snip...
!
interface FastEthernet0/1
description TRUNK verso MIO_SWITCH
no ip address
no ip route-cache
no ip mroute-cache
speed 100
full-duplex
!
interface FastEthernet0/1.1
description VLAN_A
encapsulation dot1Q 200       <--- questo lo rende prioritario rispetto gli altri link
no ip route-cache
no ip mroute-cache
no cdp enable
bridge-group 3
bridge-group 3 path-cost 6          <--- questo lo rende prioritario rispetto gli altri link
!
interface FastEthernet0/1.2
description VLAN_B
encapsulation dot1Q 201
no ip route-cache
no ip mroute-cache
no cdp enable
bridge-group 4
bridge-group 4 path-cost 6
!
interface FastEthernet0/1.3
description VLAN_C
encapsulation dot1Q 202
no ip route-cache
no ip mroute-cache
no cdp enable
bridge-group 5
bridge-group 5 path-cost 6
!
interface ATM1/0
bandwidth 155000
no ip address
no ip route-cache
no ip mroute-cache
atm sonet stm-1
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
ip address 192.168.10.1 255.255.255.252
no ip route-cache
no ip mroute-cache
atm pvc 300 10 100 aal5snap 155000 45000
bridge-group 3
!
interface ATM1/0.2 point-to-point
ip address 192.168.11.1 255.255.255.252
no ip route-cache
no ip mroute-cache
atm pvc 310 10 110 aal5snap 155000 45000
bridge-group 4
!
interface ATM1/0.3 point-to-point
ip address 192.168.12.1 255.255.255.252
no ip route-cache
no ip mroute-cache
atm pvc 320 10 120 aal5snap 155000 45000
bridge-group 5
!
ip default-gateway 10.11.12.25
no ip http server
ip classless
!
!
!
...snip...
!
bridge 3 protocol ieee
bridge 4 protocol ieee
bridge 5 protocol ieee
!
...snip....

 

Configurazione di MESSINA-2:

messina-2#sh run
 

version 12.2
...snip...
!
...snip...
no ip routing
!
...snip...
!
interface FastEthernet0/0
description verso RETE DI MONITORAGGIO-1
ip address 10.188.27.136 255.255.255.128
no ip route-cache
no ip mroute-cache
speed 100
full-duplex
no cdp enable
!
interface FastEthernet0/1
description TRUNK verso CSL-2
no ip address
no ip route-cache
no ip mroute-cache
speed 100
full-duplex
no cdp enable
!
interface FastEthernet0/1.1
description VLAN_A
encapsulation dot1Q 200
no ip route-cache
no ip mroute-cache
bridge-group 3
!
interface FastEthernet0/1.2
description VLAN_B
encapsulation dot1Q 201
no ip route-cache
no ip mroute-cache
bridge-group 4
!
interface FastEthernet0/1.3
description VLAN_C
encapsulation dot1Q 202
no ip route-cache
no ip mroute-cache
bridge-group 5
!
interface ATM1/0
no ip address
no ip route-cache
no ip mroute-cache
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
ip address 192.168.1.5 255.255.255.252
no ip route-cache
no ip mroute-cache
atm pvc 300 10 100 aal5snap 34000 10000
bridge-group 3
!
interface ATM1/0.2 point-to-point
ip address 192.168.2.5 255.255.255.252
no ip route-cache
no ip mroute-cache
atm pvc 310 10 110 aal5snap 34000 10000
bridge-group 4
!
interface ATM1/0.3 point-to-point
ip address 192.168.3.5 255.255.255.252
no ip route-cache
no ip mroute-cache
atm pvc 320 10 120 aal5snap 34000 10000
bridge-group 5
!
ip default-gateway 10.11.12.25
no ip http server
ip classless
!
!
!
...snip...

 

Qui siamo nel router di CATANIA:
 

catania-messina-155#sh span root
Bridge group 3
Root ID Priority 128
Address 0000.fabc.fa14
Cost 123
Port 9 (FastEthernet0/0.1)
Hello Time 1 sec Max Age 15 sec Forward Delay 15 sec


Bridge group 4
Root ID Priority 32768
Address 0000.f8bc.f818
Cost 82
Port 10 (FastEthernet0/0.2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec


Bridge group 5
Root ID Priority 32768
Address 0000.e8bc.fee8
Cost 82
Port 14 (FastEthernet0/0.3)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec


catania-messina-155#quindi la root e' nello switch ollegato alla eth

catania-messina-155#exit

 

 

 

Qui siamo nel router di MESSINA-1 dove 
vediamo che la root del STP e' verso Catania:
[Connection to 192.168.1.2 closed by foreign host]
messina-1#sh span root
Bridge group 3
Root ID Priority 128
Address 0000.fabc.fa14
Cost 137
Port 9 (ATM1/0.1)
Hello Time 1 sec Max Age 15 sec Forward Delay 15 sec
Bridge group 4
Root ID Priority 32768
Address 0000.f8bc.f818
Cost 96
Port 10 (ATM1/0.2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge group 5
Root ID Priority 32768
Address 0000.e8bc.fee8
Cost 96
Port 11 (ATM1/0.3)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
messina-1#
Verifichiamo che il bridging stia funzionando controllando che arrivino le bpdu da Catania:
messina-1#debug span bpdu
Spanning Tree BPDU debugging is on
messina-1#t
1d04h: STP: Bridge group 3: config protocol = ieee, packet from ATM1/0.1 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 C8 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 000000000000800000F849BEB80000007B8000000D297880D0800703000
F0001000F00
1d04h: STP: Bridge group 3 AT1/0.1:0000 00 00 00 00800000F849BEB8 0000007B 80000
00D297880D0 8007 0300 0F00 0100 0F00
1d04h: STP: Bridge group 5: config protocol = ieee, packet from ATM1/0.3 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 DC 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 0000000000800000000C1AF16400000052800000000CB37E00800D03001
40002000F00e
1d04h: STP: Bridge group 5 AT1/0.3:0000 00 00 00 800000000C1AF164 00000052 80000
0000CB37E00 800D 0300 1400 0200 0F00
1d04h: STP: Bridge group 4: config protocol = ieee, packet from ATM1/0.2 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 D2 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 0000000000800000000C1AED5800000052800000000CB369BC800C03001
40002000F00
1d04h: STP: Bridge group 4 AT1/0.2:0000 00 00 00 800000000C1AED58 00000052 80000
0000CB369BC 800C 0300 1400 0200 0F00
1d04h: STP: Bridge group 3: config protocol = ieee, packet from ATM1/0.1 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 C8 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 000000000000800000F849BEB80000007B8000000D297880D0800703000
F0001000F00
1d04h: STP: Bridge group 3 AT1/0.1:0000 00 00 00 00800000F849BEB8 0000007B 80000
00D297880D0 8007 0300 0F00 0100 0F00
1d04h: STP: Bridge group 3: config protocol = ieee, packet from ATM1/0.1 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 C8 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 000000000000800000F849BEB80000007B8000000D297880D0800703000
F0001000F00
1d04h: STP: Bridge group 3 AT1/0.1:0000 00 00 00 00800000F849BEB8 0000007B 80000
00D297880D0 8007 0300 0F00 0100 0F00
1d04h: STP: Bridge group 5: config protocol = ieee, packet from ATM1/0.3 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 DC 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 0000000000800000000C1AF16400000052800000000CB37E00800D03001
40002000F00undeb
1d04h: STP: Bridge group 5 AT1/0.3:0000 00 00 00 800000000C1AF164 00000052 80000
0000CB37E00 800D 0300 1400 0200 0F00
1d04h: STP: Bridge group 4: config protocol = ieee, packet from ATM1/0.2 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 D2 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 0000000000800000000C1AED5800000052800000000CB369BC800C03001
40002000F00
1d04h: STP: Bridge group 4 AT1/0.2:0000 00 00 00 800000000C1AED58 00000052 80000
0000CB369BC 800C 0300 1400 0200 0F00
1d04h: STP: Bridge group 3: config protocol = ieee, packet from ATM1/0.1 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 C8 00 00 AA AA 03 00 80 C2 00 0E ug all
1d04h: STP: Data 000000000000800000F849BEB80000007B8000000D297880D0800703000
F0001000F00
1d04h: STP: Bridge group 3 AT1/0.1:0000 00 00 00 00800000F849BEB8 0000007B 80000
00D297880D0 8007 0300 0F00 0100 0F00
1d04h: STP: Bridge group 3: config protocol = ieee, packet from ATM1/0.1 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 C8 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 000000000000800000F849BEB80000007B8000000D297880D0800703000
F0001000F00
1d04h: STP: Bridge group 3 AT1/0.1:0000 00 00 00 00800000F849BEB8 0000007B 80000
00D297880D0 8007 0300 0F00 0100 0F00
1d04h: STP: Bridge group 5: config protocol = ieee, packet from ATM1/0.3 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 DC 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 0000000000800000000C1AF16400000052800000000CB37E00800D03001
40002000F00
1d04h: STP: Bridge group 5 AT1/0.3:0000 00 00 00 800000000C1AF164 00000052 80000
0000CB37E00 800D 0300 1400 0200 0F00
1d04h: STP: Bridge group 4: config protocol = ieee, packet from ATM1/0.2 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 D2 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 0000000000800000000C1AED5800000052800000000CB369BC800C03001
40002000F00
1d04h: STP: Bridge group 4 AT1/0.2:0000 00 00 00 800000000C1AED58 00000052 80000
0000CB369BC 800C 0300 1400 0200 0F00
1d04h: STP: Bridge group 3: config protocol = ieee, packet from ATM1/0.1 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 C8 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 000000000000800000F849BEB80000007B8000000D297880D0800703000
F0001000F00
1d04h: STP: Bridge group 3 AT1/0.1:0000 00 00 00 00800000F849BEB8 0000007B 80000
00D297880D0 8007 0300 0F00 0100 0F00
1d04h: STP: Bridge group 3: config protocol = ieee, packet from ATM1/0.1 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 C8 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 000000000000800000F849BEB80000007B8000000D297880D0800703000
F0001000F00
1d04h: STP: Bridge group 3 AT1/0.1:0000 00 00 00 00800000F849BEB8 0000007B 80000
00D297880D0 8007 0300 0F00 0100 0F00
1d04h: STP: Bridge group 5: config protocol = ieee, packet from ATM1/0.3 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 DC 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 0000000000800000000C1AF16400000052800000000CB37E00800D03001
40002000F00
1d04h: STP: Bridge group 5 AT1/0.3:0000 00 00 00 800000000C1AF164 00000052 80000
0000CB37E00 800D 0300 1400 0200 0F00
1d04h: STP: Bridge group 4: config protocol = ieee, packet from ATM1/0.2 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 D2 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 0000000000800000000C1AED5800000052800000000CB369BC800C03001
40002000F00
1d04h: STP: Bridge group 4 AT1/0.2:0000 00 00 00 800000000C1AED58 00000052 80000
0000CB369BC 800C 0300 1400 0200 0F00
1d04h: STP: Bridge group 3: config protocol = ieee, packet from ATM1/0.1 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 C8 00 00 AA AA 03 00 80 C2 00 0E
messina-1#
1d04h: STP: Data 000000000000800000F849BEB80000007B8000000D297880D0800703000
F0001000F00
1d04h: STP: Bridge group 3 AT1/0.1:0000 00 00 00 00800000F849BEB8 0000007B 80000
00D297880D0 8007 0300 0F00 0100 0F00
1d04h: STP: Bridge group 3: config protocol = ieee, packet from ATM1/0.1 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 C8 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 000000000000800000F849BEB80000007B8000000D297880D0800703000
F0001000F00
1d04h: STP: Bridge group 3 AT1/0.1:0000 00 00 00 00800000F849BEB8 0000007B 80000
00D297880D0 8007 0300 0F00 0100 0F00
1d04h: STP: Bridge group 5: config protocol = ieee, packet from ATM1/0.3 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 DC 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 0000000000800000000C1AF16400000052800000000CB37E00800D03001
40002000F00
1d04h: STP: Bridge group 5 AT1/0.3:0000 00 00 00 800000000C1AF164 00000052 80000
0000CB37E00 800D 0300 1400 0200 0F00
1d04h: STP: Bridge group 4: config protocol = ieee, packet from ATM1/0.2 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 D2 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 0000000000800000000C1AED5800000052800000000CB369BC800C03001
40002000F00
1d04h: STP: Bridge group 4 AT1/0.2:0000 00 00 00 800000000C1AED58 00000052 80000
0000CB369BC 800C 0300 1400 0200 0F00
1d04h: STP: Bridge group 3: config protocol = ieee, packet from ATM1/0.1 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 C8 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 000000000000800000F849BEB80000007B8000000D297880D0800703000
F0001000F00
1d04h: STP: Bridge group 3 AT1/0.1:0000 00 00 00 00800000F849BEB8 0000007B 80000
00D297880D0 8007 0300 0F00 0100 0F00
1d04h: STP: Bridge group 3: config protocol = ieee, packet from ATM1/0.1 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 C8 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 000000000000800000F849BEB80000007B8000000D297880D0800703000
F0001000F00
1d04h: STP: Bridge group 3 AT1/0.1:0000 00 00 00 00800000F849BEB8 0000007B 80000
00D297880D0 8007 0300 0F00 0100 0F00
1d04h: STP: Bridge group 5: config protocol = ieee, packet from ATM1/0.3 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 DC 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 0000000000800000000C1AF16400000052800000000CB37E00800D03001
40002000F00
1d04h: STP: Bridge group 5 AT1/0.3:0000 00 00 00 800000000C1AF164 00000052 80000
0000CB37E00 800D 0300 1400 0200 0F00
1d04h: STP: Bridge group 4: config protocol = ieee, packet from ATM1/0.2 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 D2 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 0000000000800000000C1AED5800000052800000000CB369BC800C03001
40002000F00
1d04h: STP: Bridge group 4 AT1/0.2:0000 00 00 00 800000000C1AED58 00000052 80000
0000CB369BC 800C 0300 1400 0200 0F00
1d04h: STP: Bridge group 3: config protocol = ieee, packet from ATM1/0.1 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 C8 00 00 AA AA 03 00 80 C2 00 0E undebug
1d04h: STP: Data 000000000000800000F849BEB80000007B8000000D297880D0800703000
F0001000F00
1d04h: STP: Bridge group 3 AT1/0.1:0000 00 00 00 00800000F849BEB8 0000007B 80000
00D297880D0 8007 0300 0F00 0100 0F00
1d04h: STP: Bridge group 3: config protocol = ieee, packet from ATM1/0.1 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 C8 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 000000000000800000F849BEB80000007B8000000D297880D0800703000
F0001000F00
1d04h: STP: Bridge group 3 AT1/0.1:0000 00 00 00 00800000F849BEB8 0000007B 80000
00D297880D0 8007 0300 0F00 0100 0F00
1d04h: STP: Bridge group 5: config protocol = ieee, packet from ATM1/0.3 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 DC 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 0000000000800000000C1AF16400000052800000000CB37E00800D03001
40002000F00 all
All possible debugging has been turned off
messina-1#
1d04h: STP: Bridge group 5 AT1/0.3:0000 00 00 00 800000000C1AF164 00000052 80000
0000CB37E00 800D 0300 1400 0200 0F00
1d04h: STP: Bridge group 4: config protocol = ieee, packet from ATM1/0.2 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 D2 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 0000000000800000000C1AED5800000052800000000CB369BC800C03001
40002000F00
1d04h: STP: Bridge group 4 AT1/0.2:0000 00 00 00 800000000C1AED58 00000052 80000
0000CB369BC 800C 0300 1400 0200 0F00
1d04h: STP: Bridge group 3: config protocol = ieee, packet from ATM1/0.1 , link
type IEEE_SPANNING , enctype 33, encsize 12
1d04h: STP: enc 00 C8 00 00 AA AA 03 00 80 C2 00 0E
1d04h: STP: Data 000000000000800000F849BEB80000007B8000000D297880D0800703000
F0001000F00
1d04h: STP: Bridge group 3 AT1/0.1:0000 00 00 00 00800000F849BEB8 0000007B 80000
00D297880D0 8007 0300 0F00 0100 0F00
messina-1#
messina-1#


 


 

Qui siamo nel router di MESSINA-1:


messina-1#sh spann

Bridge group 3 is executing the ieee compatible Spanning Tree protocol
Bridge Identifier has priority 32768, address 0300.bbfc.fbbf
Configured hello time 2, max age 20, forward delay 15
Current root has priority 128, address 0000.fabc.fa14
Root port is 9 (ATM1/0.1), cost of root path is 137
Topology change flag not set, detected flag not set
Number of topology changes 11 last change occurred 04:13:30 ago
from FastEthernet0/1.1
Times: hold 1, topology change 30, notification 1
hello 1, max age 15, forward delay 15
Timers: hello 0, topology change 0, notification 0, aging 300

Port 6 (FastEthernet0/1.1) of Bridge group 3 is forwarding
Port path cost 7, Port priority 128, Port Identifier 128.6.
Designated root has priority 128, address 0000.fabc.fa14
Designated bridge has priority 32768, address 000f.3488.2568
Designated port id is 128.6, designated path cost 137
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 3
BPDU: sent 99314, received 0

Port 9 (ATM1/0.1) of Bridge group 3 is forwarding
Port path cost 14, Port priority 128, Port Identifier 128.9.
Designated root has priority 128, address 0000.fabc.fa14
Designated bridge has priority 32768, address 000d.2978.80d0
Designated port id is 128.7, designated path cost 123
Timers: message age 4, forward delay 0, hold 0
Number of transitions to forwarding state: 2
BPDU: sent 14, received 103260


Bridge group 4 is executing the ieee compatible Spanning Tree protocol
Bridge Identifier has priority 32768, address 0000.0ce8.4e38
Configured hello time 2, max age 20, forward delay 15
Current root has priority 32768, address 0000.f8bc.f818
Root port is 10 (ATM1/0.2), cost of root path is 96
Topology change flag not set, detected flag not set
Number of topology changes 13 last change occurred 04:13:32 ago
from FastEthernet0/1.2
Times: hold 1, topology change 35, notification 2
hello 2, max age 20, forward delay 15
Timers: hello 0, topology change 0, notification 0, aging 300

Port 7 (FastEthernet0/1.2) of Bridge group 4 is forwarding
Port path cost 7, Port priority 128, Port Identifier 128.7.
Designated root has priority 32768, address 0000.f8bc.f818
Designated bridge has priority 32768, address 0000.0ce8.4e38
Designated port id is 128.7, designated path cost 96
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 3
BPDU: sent 49708, received 0

Port 10 (ATM1/0.2) of Bridge group 4 is forwarding
Port path cost 14, Port priority 128, Port Identifier 128.10.
Designated root has priority 32768, address 0000.f8bc.f818
Designated bridge has priority 32768, address 0000.0cb3.69bc
Designated port id is 128.12, designated path cost 82
Timers: message age 5, forward delay 0, hold 0
Number of transitions to forwarding state: 2
BPDU: sent 13, received 51696



messina-1#show vlans

Virtual LAN ID: 1 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface: FastEthernet0/1

This is configured as native Vlan for the following interface(s) :
FastEthernet0/1

Protocols Configured: Address: Received: Transmitted:

Virtual LAN ID: 202 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface: FastEthernet0/1.3

Protocols Configured: Address: Received: Transmitted:
Bridging Bridge Group 5 441184 4528865

Virtual LAN ID: 201 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface: FastEthernet0/1.2

Protocols Configured: Address: Received: Transmitted:
Bridging Bridge Group 4 886955 1448106

Virtual LAN ID: 200 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface: FastEthernet0/1.1

Protocols Configured: Address: Received: Transmitted:
Bridging Bridge Group 3 1673168 12723887

messina-1#
messina-1#
messina-1#
messina-1#

 


messina-1#
messina-1#
messina-1#
*Mar 2 05:59:34: %LINK-3-UPDOWN: Interface ATM1/0, changed state to down
*Mar 2 05:59:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM1/0, change
d state to down
*Mar 2 05:59:36: %LINK-3-UPDOWN: Interface ATM1/0, changed state to up
*Mar 2 05:59:38: %LINK-3-UPDOWN: Interface ATM1/0, changed state to down
*Mar 2 06:00:11: %LINK-3-UPDOWN: Interface ATM1/0, changed state to up
*Mar 2 06:00:13: %LINK-3-UPDOWN: Interface ATM1/0, changed state to down
*Mar 2 06:00:16: %LINK-3-UPDOWN: Interface ATM1/0, changed state to up
*Mar 2 06:00:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM1/0, change
d state to up
messina-1#
messina-1#sh int
FastEthernet0/0 is up, line protocol is up
Hardware is Gt96k FE, address is 000d.2955.2490 (bia 000d.2955.2490)
Description: verso RETE DI MONITORAGGIO
Internet address is 192.168.30.120/25
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Half-duplex, 100Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
...snip...
FastEthernet0/1 is up, line protocol is up
Hardware is Gt96k FE, address is 000f.3488.2568 (bia 000f.3488.2568)
Description: TRUNK verso MIO_SWITCH
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set
Keepalive set (10 sec)
...snip...
FastEthernet0/1.2 is up, line protocol is up
Hardware is Gt96k FE, address is 000f.3488.2568 (bia 000f.3488.2568)
Description: VLAN_B
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 201.
...snip...


ATM1/0 is up, line protocol is up
Hardware is RS8234 ATMOC3
MTU 4470 bytes, sub MTU 4470, BW 155000 Kbit, DLY 80 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ATM, loopback not set
Encapsulation(s): AAL5
1023 maximum active VCs, 3 current VCCs
VC Auto Creation Disabled.
VC idle disconnect time: 300 seconds
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/51/0 (size/max/drops/flushes); Total output drops: 135
Queueing strategy: Per VC Queueing
5 minute input rate 482000 bits/sec, 191 packets/sec
5 minute output rate 162000 bits/sec, 50 packets/sec
20624165 packets input, 3641052845 bytes, 0 no buffer
Received 13375762 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 24 overrun, 0 ignored, 0 abort
3076888 packets output, 574260738 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 output buffer failures, 0 output buffers swapped out


ATM1/0.1 is up, line protocol is up
Hardware is RS8234 ATMOC3
Internet address is 192.168.10.1/30
MTU 4470 bytes, BW 155000 Kbit, DLY 80 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ATM
13789297 packets input, 3091608587 bytes
1732975 packets output, 432415963 bytes
0 OAM cells input, 0 OAM cells output
AAL5 CRC errors : 0
AAL5 SAR Timeouts : 0
AAL5 Oversized SDUs : 0
AAL5 length violation : 0
AAL5 CPI Error : 0
Last clearing of "show interface" counters never


ATM1/0.2 is up, line protocol is up
Hardware is RS8234 ATMOC3
Internet address is 192.168.11.1/30
MTU 4470 bytes, BW 155000 Kbit, DLY 80 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ATM
1725172 packets input, 1978875176 bytes
901385 packets output, 78164329 bytes
0 OAM cells input, 0 OAM cells output
AAL5 CRC errors : 0
AAL5 SAR Timeouts : 0
AAL5 Oversized SDUs : 0
AAL5 length violation : 0
AAL5 CPI Error : 0
Last clearing of "show interface" counters never


ATM1/0.3 is up, line protocol is up
Hardware is RS8234 ATMOC3
Internet address is 192.168.12.1/30
MTU 4470 bytes, BW 155000 Kbit, DLY 80 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ATM
5109949 packets input, 2865646257 bytes
442539 packets output, 63681380 bytes
0 OAM cells input, 0 OAM cells output
AAL5 CRC errors : 0
AAL5 SAR Timeouts : 0
AAL5 Oversized SDUs : 0
AAL5 length violation : 0
AAL5 CPI Error : 0
Last clearing of "show interface" counters never

messina-1#
messina-1#


messina-1#sh int switching
FastEthernet0/0 verso RETE DI MONITORAGGIO
Throttle count 0
Drops RP 0 SP 0
SPD Flushes Fast 0 SSE 0
SPD Aggress Fast 0
SPD Priority Inputs 4562 Drops 0

Protocol Path Pkts In Chars In Pkts Out Chars Out
Other Process 646 38744 10525 631500
Cache misses 0
Fast 0 0 0 0
Auton/SSE 0 0 0 0
IP Process 15990 982603 16149 1839973
Cache misses 0
Fast 0 0 0 0
Auton/SSE 0 0 0 0
ARP Process 677 40620 261 15660
Cache misses 0
Fast 0 0 0 0
Auton/SSE 0 0 0 0
CDP Process 1773 875862 1775 688792
Cache misses 0
Fast 0 0 0 0
Auton/SSE 0 0 0 0
FastEthernet0/1 TRUNK verso MIO_SWITCH
Throttle count 0
Drops RP 0 SP 0
SPD Flushes Fast 0 SSE 0
SPD Aggress Fast 0
SPD Priority Inputs 0 Drops 0

Protocol Path Pkts In Chars In Pkts Out Chars Out
Other Process 3453 179652 18723 1198252
Cache misses 0
Fast 0 0 0 0
Auton/SSE 0 0 0 0
Trans. Bridge Process 16022 961717 845178 54115772
Cache misses 0
Fast 3085624 542734668 19238363 3295275555
Auton/SSE 0 0 0 0
Spanning Tree Process 8 1376 206188 14020208
Cache misses 0
Fast 0 0 0 0
Auton/SSE 0 0 0 0
ARP Process 26270 1576637 0 0
Cache misses 0
Fast 0 0 0 0
Auton/SSE 0 0 0 0
CDP Process 1729 743111 1743 685049
Cache misses 0
Fast 0 0 0 0
Auton/SSE 0 0 0 0
ATM1/0
Throttle count 0
Drops RP 51 SP 0
SPD Flushes Fast 0 SSE 0
SPD Aggress Fast 0
SPD Priority Inputs 0 Drops 0

Protocol Path Pkts In Chars In Pkts Out Chars Out
Other Process 1 60 1 74
Cache misses 0
Fast 0 0 0 0
Auton/SSE 0 0 0 0
IP Process 1478 174264 1575 116716
Cache misses 0
Fast 0 0 0 0
Auton/SSE 0 0 0 0
Trans. Bridge Process 873813 52454532 26165 1936647
Cache misses 0
Fast 19627808 3599240320 3079789 584613406
Auton/SSE 0 0 0 0
Spanning Tree Process 210438 9890586 49 1125
Cache misses 0
Fast 0 0 0 0
Auton/SSE 0 0 0 0
ARP Process 882148 52954736 682 50468
Cache misses 0
Fast 0 0 0 0
Auton/SSE 0 0 0 0
Virtual-Access1
Throttle count 0
Drops RP 0 SP 0
SPD Flushes Fast 0 SSE 0
SPD Aggress Fast 0
SPD Priority Inputs 0 Drops 0

Protocol Path Pkts In Chars In Pkts Out Chars Out
No traffic sent or received on this interface.


messina-1#sh span

Bridge group 3 is executing the ieee compatible Spanning Tree protocol
Bridge Identifier has priority 32768, address 000f.3488.2568
Configured hello time 2, max age 20, forward delay 15
Current root has priority 128, address 0000.fabc.fa14
Root port is 9 (ATM1/0.1), cost of root path is 137
Topology change flag not set, detected flag not set
Number of topology changes 14 last change occurred 00:37:01 ago
from ATM1/0.1
Times: hold 1, topology change 30, notification 1
hello 1, max age 15, forward delay 15
Timers: hello 0, topology change 0, notification 0, aging 300

Port 6 (FastEthernet0/1.1) of Bridge group 3 is forwarding
Port path cost 7, Port priority 128, Port Identifier 128.6.
Designated root has priority 128, address 0000.fabc.fa14
Designated bridge has priority 32768, address 000f.3488.2568
Designated port id is 128.6, designated path cost 137 Hello is pending
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 3
BPDU: sent 102600, received 0

Port 9 (ATM1/0.1) of Bridge group 3 is forwarding


messina-1#sh span sum
Root bridge for: none.
PortFast BPDU Guard is disabled
UplinkFast is disabled
BackboneFast is disabled

Name Blocking Listening Learning Forwarding STP Active
-------------------- -------- --------- -------- ---------- ----------
Bridge group 3 0 0 0 2 2
Bridge group 4 0 0 0 2 2
Bridge group 5 0 0 0 2 2
-------------------- -------- --------- -------- ---------- ----------
3 Bridge Groups 0 0 0 6 6
messina-1#
messina-1#sh span brid
Bridge group 3
Bridge ID Priority 32768
Address 000f.3488.2568
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge group 4
Bridge ID Priority 32768
Address 0000.0ce8.4e38
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge group 5
Bridge ID Priority 32768
Address 0000.0ce8.4e3c
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
messina-1#sh span root
Bridge group 3
Root ID Priority 128
Address 0000.fabc.fa14
Cost 137
Port 9 (ATM1/0.1)
Hello Time 1 sec Max Age 15 sec Forward Delay 15 sec
Bridge group 4
Root ID Priority 32768
Address 0000.f8bc.f818
Cost 96
Port 10 (ATM1/0.2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge group 5
Root ID Priority 32768
Address 0000.e8bc.fee8
Cost 96
Port 11 (ATM1/0.3)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
messina-1#sh span b?
backbonefast blockedports bridge brief

messina-1#sh span bridg
Bridge group 3
Bridge ID Priority 32768
Address 000f.3488.2568
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge group 4
Bridge ID Priority 32768
Address 0000.0ce8.4e38
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge group 5
Bridge ID Priority 32768
Address 0000.0ce8.4e3c
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec



messina-1#sh span brief

Bridge group 3
Spanning tree enabled protocol ieee
Root ID Priority 128
Address 0000.fabc.fa14
Cost 137
Port 9 (ATM1/0.1)
Hello Time 1 sec Max Age 15 sec Forward Delay 15 sec

Bridge ID Priority 32768
Address 000f.3488.2568
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Designated
Name Port ID Prio Cost Sts Cost Bridge ID Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1.1 128.6 128 7 FWD 137 32768 000f.3488.2568 128.6
ATM1/0.1 128.9 128 14 FWD 123 32768 000d.2978.80d0 128.7


Bridge group 4
Spanning tree enabled protocol ieee
Root ID Priority 32768
Address 0000.f8bc.f818
Cost 96
Port 10 (ATM1/0.2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768
Address 0000.0ce8.4e38
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Designated
Name Port ID Prio Cost Sts Cost Bridge ID Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1.2 128.7 128 7 FWD 96 32768 0000.0ce8.4e38 128.7
ATM1/0.2 128.10 128 14 FWD 82 32768 0000.0cb3.69bc 128.12


Bridge group 5
Spanning tree enabled protocol ieee
Root ID Priority 32768
Address 0000.e8bc.fee8
Cost 96
Port 11 (ATM1/0.3)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768
Address 0000.0ce8.4e3c
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Designated
Name Port ID Prio Cost Sts Cost Bridge ID Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1.3 128.8 128 7 FWD 96 32768 0000.0ce8.4e3c 128.8
ATM1/0.3 128.11 128 14 FWD 82 32768 0000.0cb3.7e00 128.13

messina-1#
messina-1#
messina-1#sh span root
Bridge group 3
Root ID Priority 128
Address 0000.fabc.fa14
Cost 137
Port 9 (ATM1/0.1)
Hello Time 1 sec Max Age 15 sec Forward Delay 15 sec
Bridge group 4
Root ID Priority 32768
Address 0000.f8bc.f818
Cost 96
Port 10 (ATM1/0.2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge group 5
Root ID Priority 32768
Address 0000.e8bc.fee8
Cost 96
Port 11 (ATM1/0.3)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec


messina-1#sh span root brief

Root Hello Max Fwd
Bridge Group Root ID Cost Time Age Delay Root Port
---------------- -------------------- ----- ---- ---- ----- ----------------
Bridge group 3 128 0000.fabc.fa14 137 1 15 15 ATM1/0.1
Bridge group 4 32768 0000.f8bc.f818 96 2 20 15 ATM1/0.2
Bridge group 5 32768 0000.e8bc.fee8 96 2 20 15 ATM1/0.3
messina-1#sh span root cost
Bridge group 3 137
Bridge group 4 96
Bridge group 5 96
messina-1#sh span root port
Bridge group 3 ATM1/0.1
Bridge group 4 ATM1/0.2
Bridge group 5 ATM1/0.3
messina-1#
messina-1#
messina-1#sh span root port
Bridge group 3 ATM1/0.1
Bridge group 4 ATM1/0.2
Bridge group 5 ATM1/0.3
messina-1#
messina-1#
[Connection to 192.168.30.120 closed by foreign host]
 

 


 

Qui siamo nel router di MESSINA-2:
 

Per vedere le caratteristiche del bridge/router:

messina-2#show span bridge
Bridge group 3
Bridge ID Priority 32768
Address 000d.2964.fcc1
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge group 4
Bridge ID Priority 32768
Address 0000.f8bc.f818
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge group 5
Bridge ID Priority 32768
Address 0000.e8bc.fee8
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Per vedere le caratteristiche del root bridge:

messina-2#show span root
Bridge group 3
Root ID Priority 128
Address 0000.fabc.fa14
Cost 167
Port 10 (ATM1/0.1)
Hello Time 1 sec Max Age 15 sec Forward Delay 15 sec
Bridge group 4
Root ID Priority 32768
Address 0000.f8bc.f818
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge group 5
Root ID Priority 32768
Address 0000.e8bc.fee8
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
 

Per vedere le caratteristiche delle istanze attive di spanning-tree:

messina-2#sh span acti

Bridge group 3 is executing the ieee compatible Spanning Tree protocol
Bridge Identifier has priority 32768, address 000d.2964.fcc1
Configured hello time 2, max age 20, forward delay 15
Current root has priority 128, address 0000.fabc.fa14
Root port is 10 (ATM1/0.1), cost of root path is 167
Topology change flag not set, detected flag not set
Number of topology changes 16 last change occurred 04:40:28 ago
from FastEthernet0/1.1
Times: hold 1, topology change 30, notification 1
hello 1, max age 15, forward delay 15
Timers: hello 0, topology change 0, notification 0, aging 300

Port 10 (ATM1/0.1) of Bridge group 3 is forwarding
Port path cost 44, Port priority 128, Port Identifier 128.10.
Designated root has priority 128, address 0000.fabc.fa14
Designated bridge has priority 32768, address 000d.2978.8280
Designated port id is 128.10, designated path cost 123
Timers: message age 4, forward delay 0, hold 0
Number of transitions to forwarding state: 1
BPDU: sent 32775, received 22360


messina-2#sh span sum
Root bridge for: Bridge group 4, Bridge group 5.
PortFast BPDU Guard is disabled
UplinkFast is disabled
BackboneFast is disabled

Name                 Blocking Listening Learning Forwarding STP Active
-------------------- -------- --------- -------- ---------- ----------
Bridge group 3          1         0         0         1         2
Bridge group 4          1         0         0         1         2
Bridge group 5          1         0         0         1         2
-------------------- -------- --------- -------- ---------- ----------
3 Bridge Groups         3         0         0         3         6



messina-2# sh span bl

Name Blocked Interfaces List
-------------------- ------------------------------------
Bridge group 3 Fa0/1.1
Bridge group 4 Fa0/1.2
Bridge group 5 Fa0/1.3

Number of blocked ports (segments) in the system : 3

Sono blocked perche' nello switch sono in amministrativo down:


MIOSWITCH>en
Password:
MIOSWITCH#sh int fast3/1
FastEthernet3/1 is administratively down, line protocol is down (disabled)
Hardware is C6k 100Mb 802.3, address is 0000.effc.feef (bia 0000.effc.feef)
Description: TRUNK verso messina-2 bridging 34Mb Oriolo
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Full-duplex, 100Mb/s
input flow-control is off, output flow-control is off
ARP type: ARPA, ARP Timeout 04:00:00
Last input 04:41:51, output 04:41:50, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/18900/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
679977 packets input, 112418627 bytes, 0 no buffer
Received 249136 broadcasts (45333 multicast)
7 runts, 4742 giants, 0 throttles
13 input errors, 2 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
0 input packets with dribble condition detected
651157 packets output, 175365789 bytes, 0 underruns
 

 

Copyright 2004 – Gianrico Fichera –

Il materiale di questa pagina non e’ sponsorizzato o sottoscritto da Cisco Systems, Inc. Ciscoâ e’ un trademark di Cisco Systems, Inc. negli Stati Uniti e in altri stati. L’autore di questa pagina non si assume nessuna responsabilita’ e non da nessuna garanzia riguardante l’accuratezza e la completezza delle informazioni presenti nonche’ da conseguenze sull’uso delle informazioni presenti in questa pagina.
Il sito web ufficiale della Cisco e’ http://www.cisco.com. Nel caso si volesse utilizzare il contenuto di questa pagina nella forma in cui e’ presentato rivolgersi all’autore scrivendo a gianrico.fichera itesys.it. E' possibile utilizzare il contenuto di questa pagina per fini didattici (non lucro) purche' si dia credito all'autore.